AndroidStudio使用的Gradle插件版本和Gradle版本对应关系

AndroidStudio使用的Gradle插件版本和Gradle版本对应关系

摘要

AndroidStudio使用的Gradle插件版本和Gradle版本对应关系,The Android Gradle Plugin and Gradle

Gradle跟Gradle插件的对应关系

Android Gradle Plugin Requires Gradle
1.0.0 - 1.1.3 2.2.1 - 2.3
1.2.0 - 1.3.1 2.2.1 - 2.9
1.5.0 2.2.1+
2.0.0-2.1.2 2.10 - 2.13
2.1.3+ 2.14.1+

参考链接 http://tools.android.com/tech-docs/new-build-system/version-compatibility

Gradle各版本下载列表

https://services.gradle.org/distributions/

比如

比如我现在的开发环境下用的 Android Gradle Plugin 版本是2.1.3
对应的Gradle版本需要选择 2.14.1

Gradle版本

build.gradle中查看 Android Gradle Plugin 版本

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.1.3'
    }
}
allprojects {
    repositories {
        jcenter()
    }
}
task clean(type: Delete) {
    delete rootProject.buildDir
}